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Welcome to Media Express 2.0.

Blackmagic Media Express 2.0 is a sophistocated software application which enables UltraStudio, DeckLink, 
Multibridge and Intensity users to capture, play back and preview video and audio via Blackmagic capture 
hardware. UltraStudio, DeckLink and Multibridge users can also master to tape, using insert or assemble edit, 
with frame accurate RS-422 device control.

Media Express 2.0 replaces all previous versions of Blackmagic Deck Control and Blackmagic Media Express. 
We hope you love the new interface and features.

Media Express has an intuitive interface and requires a 1920 x 1200, or 1280 x 800, pixel computer display to 
compliment its uncluttered appearance. The capture, playback and master views are color-coded so you will 
know at a glance which mode is being used.

Media Express uses many of the same keyboard shortcuts which are standard in the video industry so there is 
little to learn. Use j, k, l to shuttle backwards, pause and shuttle forwards, or use i and o to mark in and out 
points when batch capturing or mastering to tape. Hold down the control and shift keys to reveal a jog wheel and 
then use your mouse, with the jog wheel, for precision control of your tape deck.

VITC timecode is supported via RS-422 and RP188 timecode is supported via SDI.

UltraStudio, DeckLink and Multibridge users can use the Media List feature to log multiple clips for batch capture 
or to seamlessly play back multiple clips from a playlist and master them to tape.

Media Express can directly capture to, and play back from, DPX files or movie files.

Use the Grab Frame feature to capture still images during capture, playback or when mastering to tape. Frame 
grabs are saved in the targa (.tga) graphic file format.

Blackmagic Media Express 2.0 is not NLE software and does not have a timeline. It is a great tool when you don’t 
need the complexity of NLE software but simply want to capture, play back and output clips to tape, especially 
when working with video compositing software.
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Media List

Search field

Remote indicator

VTR / deck timecode

Video Preview

Transport Control

Mark In / Mark Out

Track enable/disable

Project name, video format  
and frame rate

Blackmagic Media Express 2.0 Interface
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Media Express preferences are accessed from Media Express>Preferences on Mac OS X or 
Edit>Preferences on Windows.

Project Video Format

Project Video Format defines the frame rate and frame size of the current project. The formats displayed are 
those supported by your model of DeckLink, Multibridge or Intensity. The screenshots on this page show the 
video formats supported by a DeckLink SDI card. If a DeckLink HD Extreme 3D card had been used, additional 
formats would have been displayed including HD 1080p 50/60 and 2K.

Capture File Format 

Capture File Format sets the video codec and file format when capturing in the current project.

On Mac OS X, the capture file format options are either QuickTime movies or DPX files. If Apple Final Cut Pro is 
installed, Media Express can capture QuickTime movies with DVCPRO/DVCPRO HD and ProRes codecs as well 
as Apple Uncompressed codecs.

On Windows, the capture file format options are either AVI movies or DPX files. A choice of Blackmagic 
Uncompressed or Motion JPEG codecs can be made when capturing to AVI movies.

Preferences in Windows

Preferences in Mac OS X

Video formats in Mac OS X

Video formats in Windows

Capture file formats in Mac OS X

Capture file formats in Windows
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The Media List holds a list of clips used in a project. When in Capture view, the Media List can be a list of clips 
to be batch-captured. Media List becomes a playlist when used in Playback or Master view. These views are 
explained later in the manual.

The Media List can contain clips that are of different codecs as long as they are of the same frame rate and size. 
The Media List is a project which can contain clips of the same frame size and frame rate.

The list can be sorted by each column heading. Columns can be rearranged and widened if desired.

The order of the clips in the list can be sorted manually by dragging and dropping within the list. Single or 
multiple clips can be dragged and dropped together.

The film strip icon on the left of the list shows whether a clip has linked media. If a clip has no linked media, 
the film strip icon displays a red “X” and selecting the clip will show a “Media Offline” message in the Video 
Preview Window.

Clips can be added to the list by:

�� double-clicking on an empty area in the list
�� selecting File > Import > Media Files

�� right-clicking on the list and selecting ‘Import Media Files’
�� capturing a clip from tape.

Right-clicking in the Media List will open a contextual menu. Depending upon the menu item chosen, Media 
Express will switch to the appropriate Capture, Playback or Master view that fits the operation. For example, 
right-clicking on a clip, and selecting “Batch Capture” while in Playback view, will cause Media Express to switch 
to Capture view and carry out the batch capture operation.

Media Express can play back files of different codecs, in the same playlist, as long as they are of the same frame 
rate and size. For example, you may have a mix of 1080p23.98 MJPEG and 1080p23.98 Uncompressed video 
clips in the same playlist and Media Express will play them out seamlessly.

Media List showing an untitled clip which is not linked to any media. Right-clicking on the missing media icon will reveal a 
contextual menu from where Batch Capture can be selected.

Contextual menu in Windows

Contextual menu in Mac OS X



Welcome6 Blackmagic Media Express – Media List6

Adding Stereoscopic 3D clips

Media Express supports stereoscopic playback of 2 individual movie clips when a DeckLink HD Extreme 3D card 
is installed in your system.

To add a stereoscopic 3D clip to the Media List:

�� select a 3D project video format that is the same frame rate as your 3D media
�� add the ‘Left eye’ file into the Media List

�� right-click on the ‘Left eye’ file and select ‘Set right eye clip’ from the contextual menu

The film strip icon on the left of the list will change into a 3D film strip icon, indicating that the item is a now 
a 3D clip comprising of 2 seperate video files.

The left and right eye clips will be displayed side by side in the Video Preview window to indicate you are 
working with a 3D video project.

If you find the left and right eyes of a 3D stereo clip have been loaded the wrong way around:

�� right-click the 3D clip in the Media List
�� select ‘Swap eyes’ from the contextual menu

Select a 3D project video format that is the  
same frame rate as your 3D media

The film strip icon on the left of the list will 
change into a 3D film strip icon
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Capture View showing the contextual menu, in the Media List, can be used to start a Batch Capture. This performs the same function as clicking the Get Clip button.
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Capture operations are performed in the Capture view (ctrl-1, cmd-1)
Capturing on the fly with DeckLink, Multibridge and Intensity. 

Ensure the Project Video Format is set to the format of video you wish to capture.

Ensure the Capture File Format is set to the format you wish to capture.

Connect a video source to an input of your DeckLink, Multibridge or Intensity. Ensure the desired input has been 
selected in the Blackmagic control panel (Windows) or Blackmagic system preferences (Mac OS X).

If deck control is required (with DeckLink or Multibridge), ensure an RS-422 serial cable is connected and “remote” 
has been selected on the deck. If an RS-422 cable is not connected, or “remote” is not selected on the deck, 
the transport controls will be grayed out and “No Remote” will be displayed in the top right corner of the Video 
Preview Window.

Enter Reel and Name information into the information area. The Name will be applied to the clip(s) which are 
about to be captured.

Before capturing, the audio channels to be captured can be switched on or off via the track enable/disable 
buttons. The video track cannot be turned off.

Click on the “Capture” button to commence capturing.

To end capture, click on the “Capture” button again or press the “Esc” key.

Logging Clips for future batch capture with DeckLink and Multibridge.

Click the Mark In button to mark the In point, or use the shortcut key i.

Click the Mark Out button to mark the Out point, or use the shortcut key o.

Click the Log Clip button to log the clip, or use the shortcut key p. The entry should now appear in the Media 
List window.

Continue logging other clips.

When logging is completed, select the clips in the Media List and either:

�� Click on the ‘Get Clip(s)’ button.
�� Right-click on the selection and select ‘Batch Capture’.
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Capturing a clip with precise In and Out timecode with DeckLink and Multibridge.

Click on the Mark In button to mark the In point or use the shortcut key i.

Click on the Mark Out button to mark the Out point or use the shortcut key o.

Click on the Get Clip button. 

Media Express will cue the tape and precisely capture the clip from the In to the Out timecode points, including 
any handles specified in the application preferences.

While capturing, if the file name (Name) of a clip already exists on the selected capture drive, the user will be 
prompted if they want to over-write the file or not. If ‘No’ is selected, the file name will be auto-incremented 
with a number.

Capturing dual stream 3D video

When Media Express is used with a DeckLink HD Extreme 3D card, you can create left and right eye 3D video 
clips by capturing 2 streams of HD-SDI video simultaneously.

�� Create a 3D project which matches the frame rate of your dual stream 3D video source.

�� Ensure you have 2 discrete HD-SDI video inputs to the HD Extreme 3D card.

Naming convention for dual stream 3D video capture

When capturing dual stream 3D in Media Express, the clip name will be applied to the left eye video.  
The right eye video will be appended with ‘_right’ text. For example, if you name the stereo clip “Clip 1”, the left 
eye clip will be called “Clip 1.mov” and the right eye clip will be called “Clip 1_right.mov”.



Welcome10 Capture10 Blackmagic Media Express – Playback10

Playback View
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Playback operations are performed in the Playback tab (ctrl-2, cmd-2)

Importing clips into the Media List

Import media into the Media List using one of the following methods:

�� Double-click on an empty area of the list.

�� Select File > Import > Media Files.

�� Right-click on the list and select ‘Import Media Files’.

�� Capture a clip from tape.

Any of these actions will reveal an Open Video Clip window where more where one or more files can be selected.

If the files being imported match the frame rate and size of those in the Media List, the import will be successful.

If the files being imported do not match the frame rate and size of existing clips in the Media List, the user will be 
prompted to create a new project and to save the current project.

If the current project has had no changes, and has already been saved, the user will only be prompted to start a 
new project as there is no need to save the existing project.

Playing back a single clip

Selecting a clip (single click) on the list will load it into the Video Preview Window.

To play back a single clip in the Media List, double click the clip and it will start playing in the Video Preview Window.

To loop the playback of the clip, click on the loop button in the transport control. The selected clip will now play 
back and loop until the user clicks on the pause button or presses the spacebar.

Playing back multiple clips

To play back multiple clips, select the clips in the Media Library and click the Play button or press the spacebar. 
Selected clips in the playlist will be played back in sequence. Unselected clips will not be played.

If no clips are selected, the whole playlist is played back, starting from the last-played clip.

Clicking on the loop button will cause the playback to loop.

During playback, the audio channels being monitored can be switched on or off via the track enable/disable 
buttons. The video track cannot be turned off.

Monitoring 3D Video

Stereoscopic 3D video can be displayed from the 2 HD-SDI outputs of DeckLink HD Extreme 3D to a suitable 
3D projector, or from the HDMI output, in the following formats: Side by Side, Line by Line, Top and Bottom.  
You can select which HDMI 3D format to output in the Blackmagic preferences.
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Master View
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Mastering to tape operations are performed in the Master view (ctrl-3, cmd-3)
Media Express can use DeckLink or Multibridge to master to tape via Insert or Assemble editing. 

Only clips that are selected in the Media List will be output to tape. If no clips are selected, it is assumed that the 
entire Media List will be output.

To master to tape, click on the Master view and ensure RS-422 device control is connected. 

Enter the In and Out points of the tape by entering timecode into the respective text boxes, or by cueing the tape 
to the desired point via the transport control and then clicking the Mark In button, or use the shortcut key i.

If no Out point is entered, Media Express will set the duration of the edit to the total length of the clips in the 
Media List. If an out point is defined, Media Express will leave edit mode once the Out point timecode is reached, 
even if some clips have not been output.

The Insert and Assemble buttons are mutually exclusive and only one mode can be selected at a time.  
This determines which mode Media Express will use to master to tape. Select the Insert or Assemble 
button as required.

The Preview and Master buttons are also mutually exclusive. Clicking on either button will instruct Media Express 
to proceed with the specified operation. Preview mode mimics the edit process but does not record to tape.  
This mode allows one to check the edit point is correct.

Preview edit operations should always be checked on monitors connected directly to the output of the deck to 
view the preceding video already on tape, the new video and the following video already on tape. 

If Record Inhibit is enabled either on the deck or on the tape in the deck, Media Express will display a dialog box, 
when the user clicks on the Master button, informing the user that Record Inhibit is enabled. Check the deck/tape 
and disable Record Inhibit before trying again.

Before mastering, the audio channels to be put to tape can be selected on or off via the track enable/disable 
buttons. The Video track cannot be turned off.


